Strona główna > IT, Linux, Praca, Virtual PC 2007, Wirtualizacja > Linux a Virtual PC 2007

Linux a Virtual PC 2007

Gdzieś coś kiedys obiło mi się o uszy ze Linuks na VPC nie działa, a przynajmniej nie działają X-y. Ostatnio chciałem zbadać jakieś narzędzie do zarządzania pasmem, i jak to zwykle bywa w tej kwesti Windows przegrywa na całej linii więc sięgnąłem po starą dobrą dystrubucje Debiana (stara może nie bo wersje 4) mineło już chyba nie wiem z 5 lat jak klepałem coś na Linuksie ale jednak coś tam jeszcze pamiętam. Tak czy owak DA sie odpalić podejrzewam dowolną dystrybucje Linuksa (musze tu zwracać uwagę na pisownie tego słowa bo społecznosć Linuksowa mogła by mi to wytknąć, że nawet nazwy napisać nie umiem a co dopiero coś tam zdziałać w tym środowisku ;) )

Pamiętam, że jakiś czas temu zrobiłem podejście pod Linuksa pod VPC ale w trybie graficznym była sieczka. Tym razem było tak samo, z tym, że zagłębiłem się w temat nieco bardziej. Okazuje się, że wystarczy zmodyfikować palete kolorów z 24 na 16 bitów. W Debianie można to zrobic kreatorkiem:

dpkg-reconfigure xserver-xorg

Albo poprostu wyedytować sobie plik xorg.conf czy jakiś tam inny zależy kto z czego korzysta i znalesć sekcje od kolorów i zmienić na 16 bitów.

Gorzej, że sieć nie działa do końca jak trzeba, i tu sprawa jest ciekawa. Rzecz jasna nie jest to wina Debiana, tylko VPC, bo wkoncu oficjalnie MS nie supportuje Linuksa. Chociaż jak VPC nazywało się jeszcze Connexant Virtual costam.. nim MS ich wykupił to działało wszystko jak marzenie.

Tak czy owak skorzystałem z trybu instalacji Network Install, bo nie chciało mi się sciągać całego ISO, zamiast tego wybrałem sobie co chciałem i gra. Pierwszym problemem była firmowa ISA która wymuszała autoryzacje, to było proste stworzyłem sobie custom regułkę bez autoryzacji i tyle.  Domyślnie jak chyba większośc systemów Debian skonfigurował się na DHCP, i w trybie instalacji działało to bez najmniejszych problemów (VM karta skonfigurowana w tryb Bridged z fizyczną sieciówką). Pechowo gdy system już pobrał wszystko zainstalował i się zresetował to działać przestało. Adres raz dostawał raz nie. Nawet jak dostawał to komunikacji nie było w żadną stronę. Przełączyłem odrazu w VPC w tryb Local Only, a więc wirtualna sieć, tam DHCP działało bez pudła – innych trybów nie używam więc nie sprawdzałem. Żeby nie było w trybie Bridged też się da, trzeba poprostu przejść na adresacje statyczną i wszystko gra – można pracować.

Słowem podsumowania jeszcze, skoro działa pod VPC, to obstawiam, że na VS też zadziała, jak z Hyper-V to jeszcze nie wiem, ale myśle ze i tam sie da.

Reklamy
  1. Brak komentarzy.
  1. No trackbacks yet.

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj / Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj / Zmień )

Zdjęcie na Google+

Komentujesz korzystając z konta Google+. Wyloguj / Zmień )

Connecting to %s

%d blogerów lubi to: